thiagotalma/yii2-jstree Widget for Yii Framework 2.0 to use JsTree

extensionjstreewidgetform

yii2-jstree

Widget for Yii Framework 2.0 to use JsTree

Latest Stable Version Total Downloads Monthly Downloads Daily Downloads Latest Unstable Version License

Installation

The preferred way to install this extension is through composer.

Either run

php composer.phar require --prefer-dist thiagotalma/yii2-jstree "~1.0.0"

or add

"thiagotalma/yii2-jstree": "~1.0.0"

to the require section of your composer.json file.

Usage

Once the extension is installed, simply use it in your code by :

<?=  \talma\widgets\JsTree::widget([
    'attribute' => 'attribute_name',
    'model' => $model,
    'core' => [
        'data' => $data
        ...
    ],
    'plugins' => ['types', 'dnd', 'contextmenu', 'wholerow', 'state'],
    ...
]); ?>

Usage without a model (you must specify the "name" attribute) :

<?=  \talma\widgets\JsTree::widget([
    'name' => 'js_tree',
    'core' => [
        'data' => $data
        ...
    ],
    'plugins' => ['types', 'dnd', 'contextmenu', 'wholerow', 'state'],
    ...
]); ?>

If you wanna use the contextmenu plugin and you are having issues with a not appearing menu, you should add the following css to your site:

.vakata-context {
    z-index:999 !important;
}

Statistics

Downloads
GitHub Stars
GitHub Forks

Releases

Comments



v1.0.0 is the latest of one release



BSD 3-Clause license
Stats
30 github stars & 15 github forks
31 downloads in the last day
522 downloads in the last 30 days
14579 total downloads